Schlagwort-Archive: apache2

Webserver zu Nginx gewechselt

Da ich in letzter Zeit immer häufiger Probleme damit hatte das ich eigentlich zu wenig RAM auf dem Server habe, habe ich mich heute kurzerhand entschlossen vom Apache2 Webserver zum deutlich schlankeren Nginx zu wechseln. Ich hoffe das der Arbeitsspeicher dadurch etwas entlastet wird.
Sollte etwas nicht funktionieren gebt mir einfach bescheid.

Edit: Auch wenn im frontend alles funktionert hat, im backend sah das leider etwas anderes aus. Da auch die Ram Probleme nicht wirklich besser wurden habe ich mich entschieden doch wieder zu apache2 zurück zu kehren. Zudem habe ich einen ganz interessanten Beitrag gelesen das nginx wohl noch nicht wirklich bereit ist als einziger webserver zu fungieren, sondern im moment seine vorteile vor allem durch die kombination aus apache2 im hintergrund und nginx im vordergrund zutage bringt.

 

update von apache2 2.2 auf 2.4

so es war wieder einmal soweit. es standen updates auf meinem server an. zum einen wurde ubuntu von 12.04 LTS auf 14.04 LTS geupdatet und somit hat sich auch apache2 von 2.2 auf 2.4 geupdatet.
während um apache herum alles ganz gut lief gab es bei selbigem leider einige probleme. bei 2.4 hat sich einiges an der syntax der config geändert und somit funktionierte die alte nicht mehr. außerdem gab es einiges installationsprobleme mit dem mod spamhaus.
ich musste also erst apache komplett inklusive konfig deinstallieren mitlles

aptitude remove apache2

und es danach erneut installieren und konfigurieren.

die zuvor gesicherten virtual hosts konnte ich weiterhin verwenden jedoch musste ich eine kleine änderung daran vornehmen.

im ersten schritt mussten die dateinamen in „sites-available“ mit einem .conf am ende versehen werden.
zum zweiten muss in der Directory klammer ein Require all granted eingefügt werden. das sieht dann in etwa so aus:

<Directory /home/teamspeak/web>
          Require all granted
                Options Indexes FollowSymLinks MultiViews
                AllowOverride ALL
                Order allow,deny
                allow from all
        </Directory>

nun können die sites wieder mit a2ensite aktiviert werden.

nachdem diese Fehler nun alle behoben sind sollte hier alles wieder wie gewohnt funktionieren.
Sollte etwas bei euch nicht so funktionieren meldet euch doch bei mir.